Vectorworks System Requirements

Prerequisite for the comfortable use of Vectorworks

Hardware Requirements

Here you will find the system requirements for the current version Vectorworks 2022. For other Vectorworks versions, please refer to the Vectorworks homepage .

Former: For small projects, simple models/drawings with a low level of detail, simple renderings (e.g. small residential projects, small theaters, small landscape design)
Advanced: For medium-sized projects, complex models/drawings with medium level of detail (e.g. small commercial projects, medium-sized entertainment facilities, modeling of residential areas)
Professional: For large projects, complex and very detailed models/drawings, complex renderings (e.g. large BIM projects, large entertainment facilities, commercial areas, GIS, high-quality landscaping, photorealistic renderings)

Beginner Advanced Professional

Processor

Intel Core i5 or AMD Ryzen 5, or better
Apple M1 or later
> 2.0 GHz Intel Core i7 or AMD Ryzen 7 with 6 cores, or better
Apple M1 Pro or higher
> 3.0 GHz Intel Core i7 or AMD Ryzen 7 with 8 cores, or better
Apple M1 Max or higher

RAM

> 8 GB
> 16 GB
> 32 GB

Graphics card*

Dedicated graphics card with > 2GB VRAM and OpenGL 4.1 support.
Dedicated graphics card with > 3GB VRAM and OpenGL 4.1 support.
Dedicated graphics card with > 8GB VRAM and OpenGL 4.1 support.

Screen resolution

Mind. 1440 x 900 pixels
Mind. 1920 x 1080 pixels
Mind. 1920 x 1080 pixels

Hard disk

> 10 GB free space on HDD hard drive
> 10 GB free space on HDD hard drive
> 10 GB free space on SSD hard drive

Operating system

Which Vectorworks version requires which operating system?

Windows 11
Windows 10 64-bit
macOS 12 (Monterey)
macOS 11 (Big Sur)
macOS 10.15 (Catalina)
Windows 11
Windows 10 64-bit
macOS 12 (Monterey)
macOS 11 (Big Sur)
macOS 10.15 (Catalina)
macOS 12.1 (Monterey)
macOS 10.14 (Mojave)
macOS 10.13 (High Sierra)
macOS 10.12 (Sierra)
Windows 10 64-bit
Windows 8 64-bit
Windows 7 SP1 64-bit
macOS 11 (Big Sur)
macOS 10.15 (Catalina)
macOS 12.1 (Monterey)
macOS 10.14 (Mojave)
macOS 10.13 (High Sierra)
macOS 10.12 (Sierra)
Windows 10 64-bit
Windows 8.1 64-bit
Windows 8 64-bit
Windows 7 SP1 64-bit
macOS 10.15 (Catalina)
macOS 10.14 (Mojave)
macOS 10.13 (High Sierra)
macOS 10.12 (Sierra)
Mac OS X 10.11 (El Capitan)
Mac OS X 10.10 (Yosemite)
Windows 10 64-bit
Windows 8.1 64-bit
Windows 8 64-bit
Windows 7 SP1 64-bit
macOS 10.14 (Mojave)
macOS 10.13 (High Sierra)
macOS 10.12 (Sierra)
Mac OS X 10.11 (El Capitan)
Mac OS X 10.10 (Yosemite)
Windows 10 64-bit
Windows 8.1 64-bit
Windows 8 64-bit
Windows 7 SP1 64-bit
Mac OS X 10.11 (El Capitan)
Mac OS X 10.10 (Yosemite)
Mac OS 10.12 (Sierra)

Changes, errors reserved. Source: https://www.vectorworks.net/sysreq